[Moo] Referenceerror: Hash is not defined

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[Moo] Referenceerror: Hash is not defined

jbmoore
I have used Mootools off and on for years (always my favorite) and have an old Java application (developed in the late 90's) that I wanted to start updating with newer JavaScript libraries.  Back in the late 90's one used hidden frames to fake Ajax-like functions (Ajax did not exist yet across all browers).  So I'm moving those ancient functions to Mootools.  For simplicity sake and in development I'm using the latest Core and "all" of the More library (at least that is what I think I downloaded).

But I keep getting the error "Referenceerror: Hash is not defined" in the error log in MooTools-More-1.6.0-compat.js on line 8126. 

//<1.2compat>
HtmlTable.Parsers = new Hash(HtmlTable.Parsers);
//<1.2compat>

Everything works though???  Just this nuance error pops up when a page loads that has the MooTools libraries.  Firefox shows that both library files are loading without error..   I see it is part of the compat code so why is this choking.. am I missing something I should have downloaded.??

Here are some environment stats if that helps..

Local Server - Apache and Tomcat
Mac OSx 10.8
Firefox 48.0.2

Any thoughts on squashing this error is appreciated..

--

---
You received this message because you are subscribed to the Google Groups "MooTools Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [May Be Spam] [Moo] Referenceerror: Hash is not defined

Sanford Whiteman
‎But you don't need the compat layer if there's no existing Moo code.

From: jbmoore
Sent: Wednesday, September 14, 2016 21:33
To: MooTools Users
Reply To: [hidden email]
Subject: [May Be Spam] [Moo] Referenceerror: Hash is not defined

I have used Mootools off and on for years (always my favorite) and have an old Java application (developed in the late 90's) that I wanted to start updating with newer JavaScript libraries.  Back in the late 90's one used hidden frames to fake Ajax-like functions (Ajax did not exist yet across all browers).  So I'm moving those ancient functions to Mootools.  For simplicity sake and in development I'm using the latest Core and "all" of the More library (at least that is what I think I downloaded).

But I keep getting the error "Referenceerror: Hash is not defined" in the error log in MooTools-More-1.6.0-compat.js on line 8126. 

//<1.2compat>
HtmlTable.Parsers = new Hash(HtmlTable.Parsers);
//<1.2compat>

Everything works though???  Just this nuance error pops up when a page loads that has the MooTools libraries.  Firefox shows that both library files are loading without error..   I see it is part of the compat code so why is this choking.. am I missing something I should have downloaded.??

Here are some environment stats if that helps..

Local Server - Apache and Tomcat
Mac OSx 10.8
Firefox 48.0.2

Any thoughts on squashing this error is appreciated..

--

---
You received this message because you are subscribed to the Google Groups "MooTools Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "MooTools Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [May Be Spam] [Moo] Referenceerror: Hash is not defined

Sérgio Crisóstomo
Like Sanford commented you don't need the compat layer if you are writing new code.
Check also that both Core and More are non-compat. 

That line of code you showed is from More's HtmlTable.Sort.js and it might be you downloaded Core non-compat and More compat. 
You should use both non-compat.

Cheers

On Thu, Sep 15, 2016 at 3:43 AM, Sanford Whiteman <[hidden email]> wrote:
‎But you don't need the compat layer if there's no existing Moo code.

From: jbmoore
Sent: Wednesday, September 14, 2016 21:33
To: MooTools Users
Reply To: [hidden email]
Subject: [May Be Spam] [Moo] Referenceerror: Hash is not defined

I have used Mootools off and on for years (always my favorite) and have an old Java application (developed in the late 90's) that I wanted to start updating with newer JavaScript libraries.  Back in the late 90's one used hidden frames to fake Ajax-like functions (Ajax did not exist yet across all browers).  So I'm moving those ancient functions to Mootools.  For simplicity sake and in development I'm using the latest Core and "all" of the More library (at least that is what I think I downloaded).

But I keep getting the error "Referenceerror: Hash is not defined" in the error log in MooTools-More-1.6.0-compat.js on line 8126. 

//<1.2compat>
HtmlTable.Parsers = new Hash(HtmlTable.Parsers);
//<1.2compat>

Everything works though???  Just this nuance error pops up when a page loads that has the MooTools libraries.  Firefox shows that both library files are loading without error..   I see it is part of the compat code so why is this choking.. am I missing something I should have downloaded.??

Here are some environment stats if that helps..

Local Server - Apache and Tomcat
Mac OSx 10.8
Firefox 48.0.2

Any thoughts on squashing this error is appreciated..

--

---
You received this message because you are subscribed to the Google Groups "MooTools Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "MooTools Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "MooTools Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

[Moo] Re: Referenceerror: Hash is not defined

jbmoore
In reply to this post by jbmoore
Thank you both for the feedback.

I suspect I will need the compat version as I will be adding functions that I have programmed in past versions that I don't necessarily want to re-program at this point.

"That line of code you showed is from More's HtmlTable.Sort.js and it might be you downloaded Core non-compat and More compat. 
You should use both non-compat."

Ah, that is the hint I needed.. I had not seen the compat version of the core until I just found the "builder"..  I'll test that now..

Thanks..

--

---
You received this message because you are subscribed to the Google Groups "MooTools Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

[Moo] Re: Referenceerror: Hash is not defined

jbmoore
In reply to this post by jbmoore
That did the trick, Thanks so much for that hint...

--

---
You received this message because you are subscribed to the Google Groups "MooTools Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.